The Tulip Edge MC and Edge IO devices have replaced the I/O Gateway device. Learn More

The Tulip Edge device IP address depends on your network. In general, the Edge device will take the IP address that is given by your network. 

Some networks are configured to dynamically allocate IP addresses to devices that come onto the local network. Other networks are more restrictive and may require further information about the Edge device

In the case that your network uses DNS to dynamically allocate IP addresses, an IP address will be assigned to the Edge device upon initial setup

In this case, you will be able to see the IP in your Tulip account after selecting the Edge device on the Stations page:

If your network requires more specific Edge device information, each Edge device will appear on your network with their hostname corresponding to the Edge device serial number. For instance, the Edge device with a serial number of GTW-04-7C672D2F will have a corresponding hostname of "GTW-04-7C672D2F" that should appear on your network with other device information such as MAC address. 

The hostname or MAC address can be used to allow the device onto the network or to assign a static IP for the Edge device.

Troubleshooting

There are two typical cases where the Edge device will not be given an IP address. When performing the initial Edge device authentication to your Tulip account, if the Edge device is not able to get an IP address you will not be able to proceed with setup and you will see the following error on the first step of setup: 

In this case you should confer with your IT department to setup a hostname whitelist or enable dynamic DNS for the network. For your IT department to create a hostname whitelist, all Edge device hostnames start with "GTW-" prefix. Your IT department can use that as a means of filtering hostnames.

A second consideration is when you have already successfully set up an Edge device on your network and then the Edge device is no longer "connected" to your Tulip account. 

In this case, if you go to the Stations tab in your Tulip account, the Edge device icon will appear similar to the following image: 

Where the red icon indicates that the Edge device is offline, i.e. not connected. In this case you should do the following:

  • Ensure that the ethernet cable is securely attached.

  • Ensure that the Edge device is connected to a valid network.

  • Confer with your IT department to see if there have been rule changes that may have excluded your Edge device. An example is that the IT department stopped dynamically issuing IPs, in which case they will need to add the Tulip Edge device hostnames to their hostname whitelist.

See this guide for more troubleshooting details.

Did this answer your question?